Windowsプリンタードライバー

プリンタードライバーとはなにか?

プリンタードライバーはデータ(通常グラフィックと文字)をプリンター固有のコマンドに変換するソフトウエアの一つです。ドライバーは印刷ジョブを生成します。印刷ジョブは各プリンター固有のコマンドで生成されています。プリンタードライバーの目的は、共通の印刷命令を各プリンター固有のコマンドに変換して、アプリケーションがプリンターを意識することなく描画できるようにすることです。

Windows環境では標準の印刷システムを使用するすべてのアプリケーションが、同じプリンタードライバーを使用できます。ドライバーはアプリケーションとプリンターを繋ぐ架け橋になります。プリンターが熱転写、感熱、剥離機、インクジェット、またはレーザーなどのどのような方式であっても使用することができます。

プリンタードライバーはどのように動作するか?

プリンタードライバーは操作するプリンタの特性を把握しています。アプリケーションはプリンタードライバーに機能、例えば使用可能な用紙サイズ、内蔵フォントやバーコード、カッターのサーポート、カウンターやRFIDなどを知り、 アプリケーションはこれらのプリンター機能をユーザーに提示することができます。ユーザーはこれらの機能を選択して、ドキュメント/ラベルデザインの最適化と印刷の高速化のために利用できます。印刷にこれらの機能を利用できないときは、ドキュメントはGDIモードで動作します。この場合はドキュメントはグラフィックとして処理され、全てのオブジェクトはイメージに変換されて印刷されます。

ドライバーはドキュメントをプリンターが利用可能なコマンドに変換し、Windowsスプーラに印刷ジョブを作成します

高性能な産業用プリンターは、通常動的に変化するオブジェクトや特殊なオブジェクト、例えばカウンターやバーコードなどを印刷する能力があり、印刷のパフォーマンスを向上させるために利用できます。印刷を最適化するための詳しい情報は、印刷速度の最大化をご覧ください。

ノート: 高度な印刷と印刷ファイル処理をサポートするSATOプリンタードライバーは、SATO専用ドライバーだけです。この意味は、このドライバーだけがSATOアプリケーションで完全な動作をするということです。SATOプリンタードライバーを使用すると、SATOラベルとソリューションが使用可能な全ての構成で、最適な印刷を得ることができます。


コマンドラインインポートツール

ドライバーのユーザーインタフェイスを使用せずに素早くプリンター設定のインポートやエクスポートをするには、コマンドラインインポートツールを使用します。コマンドファイル(バッチファイル)を使用して、自動的にプリンター設定のインポートやエクスポートができます。

コマンドラインツールは、ドライバーインストールメディアのImportExportTool.exeToolToolsフォルダにあります。

コマンドラインツールの文法は以下の通りです：

ImportExportTool.exe <Printer_name> <File_name> <import|export>

全てのパラメータが必須です。

  • Printer_name. ディバイスとプロパティのプリンター名で表示されている、プリンターの正確な名前です。プリンター名に空白文字が含まれている場合は、ダブルクオートで囲って下さい。
  • File_name. 設定をエクスポートするファイル名、または設定をインポートするデータが含まれるファイル名です。
  • Import|export. コマンドラインツールの動作。Exportを指定すると、設定をファイルにエクスポートします。Importを指定すると、ドライバー設定をファイルから読み込んで設定します。


プリンターフォントとスクリーンフォントの比較

プリンターフォントは、プリンターに予め搭載されているフォントです。プリンターを選択すると、そのプリンターの持つプリンターフォントが使用できるようになります。アプリケーションでプリンターフォントを表示するように設定すると、他のスクリーンフォントと一緒にフォントリストに表示されます。

プリンターフォントは他のスクリーンフォント、例えばTrueType、OpenType、およびPostscriptフォントなどと区別するために、 フォント名の前に異なるアイコンで表示されます。

プリンターが持つフォントの数は限定されています。また多くのフォントは固定サイズであり、段階的なサイズにしか変更することができません。一方スクリーンフォントには、このような制限がありません。

プリンターフォントを選択することは、印刷のパフォーマンスが向上する良い方法です。フォントはプリンターに内蔵されているので、アプリケーションは印刷する位置、フォントの種類、サイズ、文字列を送信するだけで済み、 その命令サイズは数十バイト程度です。

一方スクリーンフォントの処理は、常に長い時間を要します。ドライバーは、スクリーンフォントデータをビットマップに変換して送信します。ビットマップの数とサイズが増えるにつれ、印刷速度は低下します。多くのビットマップは、印刷と送信に時間を要します。その命令サイズは、容易にキロバイト単位になります。特に通信速度の遅いインタフェース、例えばシリアルポートを使用しているときは速度の低下が顕著です。

プロフェッショナルなラベルプリンターは、リアルタイムクロック、カウンターなどの変数オブジェクトをサポートしています。このようなオブジェクトを使用すると、ソフトウエアからの送信を必要とせずにプリンター自身が日時やカウンターデータを生成することができます。このようなオブジェクトを使う時も、プリンターフォントを使用してレイアウトする必要があります。


プリンターステータスチェック

プリンタードライバーは双方向通信によるプリンターステータスチェックをサポートしています。この機能はプリンターのステータスレポートをリアルタイムで知ることができます。

ステータスメッセージはプリンターのブランド、モデル、および能力に強く依存します。ある機種はOK、またはエラーのみを通知しますが、リボン切れ、ラベル切れ、リボン残少などを通知できる機種もあります。

プリンターステータスを正しくチェックするには、以下の条件を満さなければいけません:

  • プリンター自体に双方向通信機能がある
  • 双方向通信機能を持ったドライバーを使用する
  • プリンターをネットワークに接続しているなら、アドバンスドポートモニターを使用している
Closed パラレル、シリアル、およびUSBを使用した通信

プリンターをパラレル、シリアル、またはUSBに接続しているときは、追加の設定は必要ありません。

Closed TCP/IPポートを使用したネットワーク接続

プリンタードライバーが印刷ファイルを生成すると、ファイルはWindowsスプーラーに送られます。次にスプーラーはファイルをプリンターに送ります。Windowsスプーラーはポートモニターを使用してこのタスクを実行します。

Windowsポートモニターはラベルプリンターがパラレル、シリアル、 またはUSBに接続されることを前提にデザインされています。しかしWindowsポートモニター(標準TCP/IPポートモニター)は、ネットワークラベルプリンターが必要とするすべての機能をサポートしていません。これがSATOポートモニター(アドバンスドポートモニター)をインストールしなければいけない理由です。インストールはドライバーのインストールのとき、または後でもインストールすることができます。

以下の手順をおこないます：

  1. PrnInstドライバーインストールウイザードを実行します
  2. プリンターが接続されているポート選択のウインドウ(ネットワークポートの選択ウインドウ)が表示されたら、新しいネットワークポートの作成オプションを選択します
  3. ネットワークポートの追加ウインドウが開きます
  4. ネットワークポートのプロパティを入力します: 名前、IPアドレス、およびポート番号(通常9100)
  5. 次へをクリックしてドライバーのインストールを完了します
  6. 以上の手順でAdvanced Port Monitorがインストールされ、プリンタードライバと共に利用可能になります。


印刷速度の最大化

印刷速度は利用するポートの種類、ポート設定、プリンター設定などさまざまな要素に影響を受けます。ここでは印刷速度に影響を及ぼす最も一般的な内容について説明します。

Closed 高速な通信インターフェイスを使用する

大量の印刷を行うときは、選択可能な最も高速なインタフェースを使用してください。ネットワーク(TCP/IP)やUSBインタフェイスは、パラレルやシリアルインタフェースより高速です。ネットワークプリンターを設定するときは、プリンターステータスチェック の章も読んでください。

Closed プリンターの内蔵フォントを使用する

TrueTypeフォントを使用した印刷は、多くのデータをプリンターに送信する必要があるので長い時間がかかります(特に低速なインターフェイスに接続しているとき)。ドライバーは各TrueTypeオブジェクトをビットマップデータに変換します。そのため印刷データは大きくなり、プリンターへの送信と印刷に長い時間を要します。

通常ラベルプリンターは複数の内蔵フォントを持っています。ラベルアプリケーションでは、TrueTypeフォントとは区別できるアイコンで内蔵フォントを表示します。内蔵フォントを使用すると文字列と使用するフォントの情報だけが送信されます。これは印刷データを抜本的に減少させるので、高速な印刷が可能になります。

Closed 印刷速度(用紙搬送速度)を高速にする

プリンターの印刷速度(用紙搬送速度)を高速にできます。詳細については 印刷オプションの章を参照してください。

印刷速度を高速にすることは印刷品質の低下につながります。テストによって、適切な印刷速度と濃度設定をしてください。

Closed ラベル上で使用するグラフィックを最小にする

ラベル上でグラフィックを使用することをなるべく避けてください。グラフィックデータの送信は長い時間を要します。

会社のロゴのような、よく利用するグラフィックは、あらかじめ印刷されたラベルを使用することをお勧めします。


インポート/エクスポート

インポート/エクスポート パネルのプロパティでは、現在のドライバー設定をエクスポート して同じ、または異なるコンピューターの互換性のあるプリンタードライバーに適用します。

プリンタードライバーの現在の設定を外部ファイルに保存し、バックアップや設定の配布目的で使用する事ができます。ドライバー設定を同じ、または異なるコンピューターにインポートすると、 プリンタードライバーの設定を複製する事ができます。

エクスポートしたファイルにはドライバー設定、ユーザー定義ストック情報などが含まれています。これら全ての設定は、DRXという拡張子を持つ単一のファイルに保存されます。設定は互換性のあるプリンター間で交換することができます。定義ファイルに現在のプリンターで使用できない情報が含まれていれば、そのような情報は読み込まれませんが保持されます。

ノート: コマンドラインユーティリティを使って、ドライバー設定をインポート/エクスポートする事ができます。詳しい情報はコマンドラインインポートツールを参照してください。


ストック

ストックパネルのプロパティではストックライブラリーを参照、または管理します。ストックとはカスタムラベルのサイズ、いくつかのプリンター設定値をあらかじめ登録したものです(用紙設定とプリンター設定がペアになったもの)。登録したストックは、このドライバを使用するすべてのアプリケーションから利用できます。

新規ボタンをクリックすると、ストック設定ダイアログボックスが開きます。

Closed ページ設定

メディア設定

  • 名前． ストックの名前を入力します。
  • 幅． ストックの幅を入力します。
  • 高さ． ストックの高さを入力します。
  • メディアの種類． ラベルプリンターで使用するメディアの種類を選択し、センサーを設定します。通常ダイカットラベルでは、ラベルを正しくカットしたり送るために、各ラベルを検出するメカニズムを必要とします。この目的のためにラベル間を検出する反射センサーなど、様々なセンサーが使用されます。別のオプションは、ラベルの前に印刷した黒いマークを検出するセンサーなどがあります。
Closed 詳細
  • ギャップ付きラベル 最も一般的なラベルです。抜き加工された、最も一般的なラベルです。プリンターは光センサーでラベル間のギャップを検出します。ラベル間のギャップによって、プリンターは印刷ヘッドの下に次のラベルを送ることができます。
  • 連続ラベル． 抜き加工されておらず、ラベル間のギャップがないラベルです。通常は内蔵カッターによって、指定サイズで切り取られます。
  • 黒マーク付きラベル． 予め台紙に検出用の黒マークが印刷されているラベルです。黒マークによって、プリンターは印刷ヘッドの下に次のラベルを送ることができます。
Closed 他の計測単位で値を入力する

既定の計測単位以外で値を入力するには、値の後に計測単位を明示します。

計測単位には、以下の略号を使用することができます。

略号 | 計測単位
" インチ
mm | ミリメートル
cm | センチメートル


ダウンロード

ダウンロードパネルでは、グラフィックやフォントをプリンターにダウンロードして、内蔵エレメントのように使用できるようにします。

Closed フォントのダウンロード

ダウンロード > フォントをクリックするとフォントのダウンロードダイアログが開きます:

  • 選択したフォント． プリンターにダウンロードするフォント、またはフォントのスタイルを選択します。
  • フォントの送り先． ダウンロードするフォントの格納先を定義します。
  • 説明． ダウンロードするフォントに関する説明文です。

ダウンロードフォントダイアログボックスで、ダウンロードボタンをクリックします。フォントは定義した場所に格納されて利用可能になります。

Closed グラフィックのダウンロード

ダウンロード > グラフィック をクリックするとグラフィックのダウンロードダイアログが開きます:

  • 選択したグラフィック． プリンターにダウンロードするグラフィックファイルを選択します。
    • パス． パスを入力するか、 ...ボタンをクリックしてファイルを選択します。
    • プリンターメモリー． グラフィックを格納するプリンターメモリーを選択します。
  • プレビューフィールドには、選択したグラフィックファイルのプレビューが表示されます。


フォント

フォント パネルのプロパティでは仮想のフォントを定義、または管理します。新しいフォントを定義したり、既存のフォント定義を編集、または削除する事ができます。

仮想のフォントは、プリンタードライバを操作するアプリケーションから使うことができます。Windowsシステムにインストールしているように振る舞い、アプリケーションでプリンターフォントを選択する場合に表示されます。例えばバーコードフォントで入力した文字列は、アプリケーションがバーコードの印刷をサポートしていない場合でもバーコードとして印刷されます。

コマンドフォントで入力した文字列は、そのまま印刷データの中にプリンターコマンドとして埋め込まれます。

フォント置換を定義すると、スクリーンフォントをプリンター内蔵フォントに置換して印刷することができます。これは.NETのような、プリンター内蔵フォントをサポートしない環境で有用です。

詳しい情報は、以下のトピックを参照してください：

  • バーコードフォント
  • コマンドフォント
  • フォント置換


バーコードフォント

バーコードフォントパネルのプロパティではプリンタードライバーで利用可能な仮想フォントを管理することができます。作成できるバーコードフォントの数に制限はありません。各バーコードフォントは、重複しない名前をつけてください。使用するバーコードの種類を指定してから、各バーコードフォント固有のオプションを設定します。

アプリケーションでバーコードフォントを使用すると、問題を生じるかもしれません。これはバーコードフォントの仕様に従っていない場合に多く生じます。このような場合は、プロフェッショナルなラベル印刷ソフトウエアを使用する事をお勧めします。

Closed バーコードフォントの詳しい情報

殆どの熱転写プリンターは、様々なバーコードシンボルの印刷機能をサポートしています。これらのバーコードシンボルは、ラベルソフトウエアから簡単に使用できます。しかし一般にWindowsのGDIモードからはアクセスできないので、多くのアプリケーションから使用する事はできません。バーコードフォントは、この問題に対処するための仮想のフォント定義です。バーコードフォントは、本当はWindowsにインストールされていません。しかし、プリンタードライバーを使用するアプリケーションからは存在しているように見えます。バーコードフォントは他のWindowsフォントと同様に、選択したプリンターフォントの一つとして表示されます。

アプリケーションが描画する時にバーコードフォントを使うと、入力したデータをバーコード化することができます。ただしアプリケーションソフトの編集画面では、文字として表示されます。またドライバーは、アプリケーションで入力したデータを検証しません。誤ったデータの入力はバーコードが印刷されなかったり、プリンターがコマンドエラーを起こすことがあります。

Closed フォント設定
  • バーコード． バーコードの種類を選択します。入力した文字の書式に従って、選択したバーコードとして印刷されます。入力する文字は、バーコードとプリンターの仕様に従わなければいけません。例えばいくつかのバーコードは、固定長の文字列と数字のみを使用できます。
  • 名前． アプリケーションで表示される、仮想のプリンターフォント名を指定します。ここで指定した名前のフォントはTrueTypeや、その他のフォントの一つとして表示されます。
  • 説明． フォントが意図している機能についての簡潔な説明を記述します。バーコードフォントは高度な機能なので、その内容についての説明を書くことは重要です。
  • マージ内容．

マージ対象． このセクションのオプションは、データを1つの行に、またはページ全体を1つのコンテンツにマージします。複数のオブジェクトから供給されるデータを1つのオブジェクトにエンコードしたいときは、マージを使って1つのストリームにしなければいけません。

このオプションは通常、2次元バーコードやRFIDタグなどの複数のデータフィールドを、1つのデータフィールドとして構成するときに使用します。また一部のWindowsアプリケーションは、1つの文字列を複数の文字列に分解して送信するので(Microsoft Wordなどが知られています)、 コマンドが1度だけ適用されることを保証するためにも使用します。

  • マージしない． マージしません。呼び出しのたびに送信されます。
  • 同一行の文字． 同じフォントを使う同一行の文字に対して、1度だけ送信されます。
  • 同一ページの文字． 同じフォントを使う同一ページの文字に対して、1度だけ送信されます。
Closed バーコード設定

このオプションは、選択したバーコードについて設定します。表示される内容は、選択したバーコードに依存します。

  • 回転． 選択したバーコードの印刷方向を設定します。90°単位で設定できます。
  • ナローバー幅． バーコードを構成する最小要素の細いバーの幅を入力します。"X 比率"とも言います。バーコードは異なる幅のバーで構成されています。すべてのバーは、ナローバーの幅の倍数になります。この値はバーコードのサイズと密度に影響をします。

  • 高さ． バーコードの高さを指定します。

    デザインしたラベルがバーコードフォントを含む場合は、実際に印刷されるバーコードの高さはバーコードフォントサイズに基づいて計算されます。

    シンボルの高さは、バーコードフォントのサイズに相互して拡大、または縮小されます。

    特定のバーコードで印刷時に正しい高さを得るためには、修正の計算が必要です。

    以下は、プリンタードライバーが様々なバーコードフォントの高さを計算する式です:

    • UPCA:
      • 拡大 1: 印刷高さ = バーコードフォント高さ - 5 ドット
      • 拡大 2: 印刷高さ = バーコードフォント高さ - 12 ドット
      • 拡大 3: 印刷高さ = バーコードフォント高さ - 10 ドット
      • 拡大 4: 印刷高さ = バーコードフォント高さ - 9 ドット
      • それ以外の全ての拡大: 印刷高さ = バーコードフォント高さ - 12 ドット
    • UPCE (プリンタードライバーはヒューマンリーダブル文字を自動的に生成します):
      • 印刷高さ = 高さ - 4 * 拡大
    • EAN8:
      • 拡大 1–4: 印刷高さ = 高さ - 3 * 拡大
      • 拡大 5–6: 印刷高さ = 高さ - 2 * 拡大
    • EAN13:
      • 拡大 1: 印刷高さ = 高さ - 3 ドット
      • 拡大 2: 印刷高さ = 高さ - 6 ドット
      • 拡大 3: 印刷高さ = 高さ - 6 ドット
      • 拡大 4: 印刷高さ = 高さ - 8 ドット
      • 拡大 5: 印刷高さ = 高さ - 10 ドット

    ヒューマンリーダブル． ヒューマンリーダブル(解説文字)を付けるか指定します。ヒューマンリーダブルとは、通常バーコードの下に付く可読文字です。バーコードにコード化された文字が表示されますが、バーコードによっては規格で必要な文字が付加されていたり、代替文字で表示されていることがあります。

    パススルーモード. プリンターに送信する時のエンコードを無効化します。これはWindowsアプリケーションから送信される文字列に介在せず、ありのままにプリンターに送信される(完全に自由な制御が可能な)モードであることを意味します。

  • ヒューマンリーダブル． ヒューマンリーダブル(解説文字)を付けるか指定します。ヒューマンリーダブルとは、通常バーコードの下に付く可読文字です。バーコードにコード化された文字が表示されますが、バーコードによっては規格で必要な文字が付加されていたり、代替文字で表示されていることがあります。
  • パススルーモード. プリンターに送信する時のエンコードを無効化します。これはWindowsアプリケーションから送信される文字列に介在せず、ありのままにプリンターに送信される(完全に自由な制御が可能な)モードであることを意味します。

ノート: エンコードは正しい印刷結果を得るために重要です。パススルーモードは、Code128、Code128-A、Code128-B、Code128-C、またはGS1-128バーコードを選択した場合に使用することができます。

  • 比率． ナローバーとワイドバーの比率を指定します。この機能が使用できるかはバーコードに依存します。例えば比率に2:5を指定すると、ナローバーの幅2に対してワイドバーの幅は5になります。
  • チェックジッドの自動生成． チェックジッドを自動的にバーコードデータに付けるか指定します。チェックジッドとは、いくつかのバーコードの末尾に付く文字で、 エラーを検出のために数学的に計算される値です。いくつかのバーコードでは、必ずチェックでジッドを付けなければいけません。スキャナはチェックデジッドが付いたバーコードを読むと、スキャナが計算したチェックデジッド値と読み取ったチェックデジッド値を比較します。値が同じであれば正しく読み取られたことが保証できます。
Closed シンボル固有のオプション
Closed EAN/UPC/JANコード
  • ガードバー． ガードバーとはバーコードの最初、中央、最後の長く延長したもので、桁を区切ってヒューマンリーダブルを読みやすくするために使われます。EAN/UPC/JAN規格は、ガードバーを使用することを要求しています(無くともリーダーの読み取りには影響しません)。
Closed QRとMicro QR
  • マスク． コード化する時に使用するマスクパーターンで、特別な意味を持つビット並びが偶然生じないようにするために指定します。通常は既定の自動生成を選択してください。殆どの場合で自動生成が最も適切なパターンです。
  • エラー訂正レベル． バーコードデータの欠損に備えて作られる"バックアップ"データのレベルです。高いエラー訂正レベルを使用すると欠損に強くなりますが、同じ密度とサイズで格納できるデータ量が減ってしまいます。
  • モデル． QRコードシンボルの種類です。モデル2は新しい規格で、モデル2を使用することが推奨されています。
Closed DatamatrixとGS1 Datamatrix
  • モジュールの幅と高さ． Datamatrixは白黒の正方形、または長方形のモジュールで構成されています。各モジュールの幅と高さを指定します。
  • シンボルサイズ． シンボルのサイズを指定します。多くのデータが入力されると行と列のサイズは大きくなります。
Closed PDF417
  • モジュールの幅と高さ． PDF417は、17のモジュールを持つ4つのバーコードから構成されています。各モジュールの幅と長さを指定します。
  • セキュリティレベル． バーコードデータの欠損に備えて作られる"バックアップ"データのレベルです。高いエラー訂正レベルを使用すると欠損に強くなりますが、同じ密度とサイズで格納できるデータ量が減ってしまいます。
  • 行と列のアスペクト比． PDF417は、バーコードシンボルのアスペクト比(行と列の比率)を変更できます。アスペクト比を変更するとシンボルを長方形、または正方形に変形することができます。アスペクト比の変更は、通常バーコードリーダーの読み込みには影響を与えません。このオプションは印刷サイズの調整に使用します。
Closed カスタマーバーコード

カスタマバーコードは、日本郵便株式会社で使用されるバーコードです。バーコードデータには2つのフィールドがあります：

  • 郵便番号． 7桁の郵便番号です。
  • 印刷データ． 13桁以内のデータで、 A-Zの英字、0~9の数字、およびハイフン(-)が使用できます。

データを与えるときは、パイプ文字(|)でフィールドを区切ってください。フィールドの順序は重要です。詳細については、この章の後ろのトピックを参照してください。

Closed 合成シンボル(Composite)バーコード

合成シンボルコードを選択すると、GS1合成シンボルバーコードを印刷できます。シンボルは1次元バーコードと、複数の行から構成される2次元バーコード(CC)を含んでいます。2次元バーコードは、1次元バーコードの上に印刷されます。

  • 1次元コンポーネント． 最大長は選択した1次元バーコードに依存します。GS1-128シンボルは48桁、EAN/UPCシンボルは8、12、または13桁、GS1 DataBar Expandedは74桁以下、その他のGS1 DataBarシンボルは16桁以下です。
  • 2次元コンポーネント． 最大長は選択した2次元バーコード(CC)に依存します。CC-Aは56桁以下、CC-Bは338桁以下、CC-Cは2,361桁以下です。CC-AはMicroPDF417の別名、CC-Bは新しいエンコーディング形式のMicroPDF417、CC-C は新しいエンコーディング形式のPDF417で、GS1-128でのみ使用する事ができます。

データを与えるときは、パイプ文字(|)でフィールドを区切ってください。フィールドの順序は重要です。詳細については、この章の後ろのトピックを参照してください。

Closed セキュリティQRコード(SQRC)

SQRCは暗号化パートと非暗号化パートを持つQRコードの一種です。SQRCの外見は、通常のQRコードと違いがありません。SQRCは以下のフィールドを指定します

  • パスワード(暗号化キー)． 16桁の文字列(16進数)。
  • プライベートデータ(暗号化パート)． 486文字以内のデータ。
  • パブリックデータ(非暗号化パート)． 486文字以内のデータ。

SQRCをサポートしないスキャナーで読み取るとパブリックデータのみが返され、通常のQRコードのように振舞います。プライベートデータを読み取るには、SQRCをサポートするスキャナーを使用し、パスワードが一致しなければいけません。

データを与えるときは、パイプ文字(|)でフィールドを区切ってください。フィールドの順序は重要です。詳細については、この章の後ろのトピックを参照してください。

Closed Maxicode

Maxicodeは荷物の出荷管理と追跡に適したバーコードです。このバーコードはUnited Parcel Service (UPS)によって作られました。Maxicodeは約93文字の情報を格納することができます。

Maxicodeのモード2と3は、構造化キャリアーメッセージと呼ばれるデータ構造を持っています。これらは以下のフィールドを含んでいます：

  • 宛先郵便番号
  • 宛先ISO国コード
  • サービス等級
  • 追跡番号
  • UPSアカウント番号
  • ユリウス暦のピックアップ日付
  • シッピングID番号
  • パッケージ数
  • パッケージ重量
  • 住所検証済み(Y、またはN)
  • 宛先住所
  • 宛先市町村
  • 宛先都道府県

ノート: モード2(数字の郵便番号を含む構造化キャリアメッセージ)は、米国国内輸送を目的としています。モード3(英数字の郵便番号を含む構造化キャリアメッセージ)は、主として国際輸送を目的としています。

データを与えるときは、パイプ文字(|)でフィールドを区切ってください。フィールドの順序は重要です。詳細については、この章の後ろのトピックを参照してください。

Closed 複数のコンポーネントを持つバーコードデータの入力

バーコードによっては、構造化されたデータ構造を持ち、 複数のコンポーネントを持つことがあります。複数のコンポーネントは、 以下の構文に従ってデータを与えて1つのデータにしなければいけません：

<フィールド 1>|<フィールド 2>|...|<フィールド n>

各コンポーネントは、パイプ文字(|)で区切ってデータを与えます。各バーコードで規定される数のデータを与えてください。与えるデータの順序も重要です。

ノート: 例えば郵便番号と配送情報の2つのフィールドを持つ郵便番号コードでは、次のように指定します："3310043|1-207"

Closed 他の計測単位で値を入力する

既定の計測単位以外で値を入力するには、値の後に計測単位を明示します。

計測単位には、以下の略号を使用することができます。

略号 | 計測単位
" インチ
mm | ミリメートル
cm | センチメートル


コマンドフォント

ノート: コマンドフォントは高度な知識を持つユーザー向けの機能です。プリンターコマンドとWindowsに関する十分な知識がない場合は使用しないでください。

コマンドフォントは、プリンターを直接制御することができる仮想のフォントです。コマンドフォントとして定義されたフォントを使用して描画(TextOut)すると、ドライバは特別な解釈を加えることなくプリンターに送信します。そのため印刷条件を微調整したり、ドライバーで直接サポートされていない機能を呼び出すことができます。Windows でプリンターを直接制御する一般的な方法は2つあります。1つ目はWritePrinter APIでコマンドを書き込む方法です。この方法ではGDIとは異なるハンドルを使うのでジョブが分離されます。2つ目はEscape　APIでコマンドを書き込む方法です。この方法では描画と同じGDIハンドルを使うので、データを混ぜることが容易になります。コマンドフォントは、Escape APIを使用した場合と似ていて、TextOut APIで処理するEscape　APIと考えることができます。オプションのパラメータで接頭、接尾文字列などを自動的に付加できるので、簡単にプリンターコードを生成できます。GDIで制御する以上、初期化や終了処理はドライバに委ねられているので注意してください。またコマンドの挿入場所を厳密に指定することもできません。従って印刷結果は意図したものにならないことがあります。

Closed コマンドフォントを理解する

コマンドフォントの構造：

[prefix] + value + [suffix]

valueは、コマンドフォントを使用するアプリケーションから渡される文字列です。prefixとsuffixは、コマンドフォント定義の接頭、接尾文字プロパティから渡される文字列定数です。prefixとsuffixには、この章で詳しく説明する予約変数を含めることができ、印刷時の情報と置換できます。prefix、value、suffixの3つを連結した文字列が印刷ストリームに挿入されます。valueは、特別な解釈を加えずに解析されます。prefixとsuffixは、印刷時に置換される制御コードの代替表記入力が可能です。

また、連結した文字列の印刷ストリーム挿入位置を調整することができます。

印刷ストリームに介入する前に、プリンターの制御言語に十分習熟しなければいけません。コマンドフォントで生成された文字列はそのままプリンターに送られ、その妥当性は検証されないので、正しいコマンドであることを十分に確認してください。プリンターが解釈できない文字列や、また誤った構文が含まれているなら、プリンターはそれらを無視するか、正常な動作をしません。

印刷運用する前には十分なテストを行ってください。

Closed コマンドフォント
  • 名前． アプリケーションで表示される、仮想のプリンターフォント名を指定します。ここで指定した名前のフォントはTrueTypeや、その他のフォントの一つとして表示されます。
  • 説明． フォントが意図している機能についての簡潔な説明を記述します。コマンドフォントは高度な機能なので、その内容についての説明を書くことは重要です。
Closed プレフィックスとサフィックス

種類． 文字列の供給方法を指定します。指定した文字列は、予約変数の置換後にコマンドの前(プレフィックス)、または後(サフィックス)に付けられます。

  • 接頭なし． プレフィックス、またはサフィックス文字列を使用しません。それぞれのコマンドフォントには、プレフィックス、サフィックス、または両方を指定することができます。
  • ファイル． プレフィックス、またはサフィックス文字列を外部ファイルから読み込んで付加します。内容ボックスに直接ファイル名を入力するか、矢印ボタンを押してファイルを参照します。ファイルの内容は印刷されるたびに読み込まれます。ドライバーはファイルの内容に特別な解釈を加えませんが、 制御コードに該当するバイトだけはこの章で説明する代替表記をしなければいけません。例えば"エスケープ" (ASCIIコードの27)は、0x1Bのように表記します。
  • ファイル分析． プレフィックス、またはサフィックス文字列を外部ファイルから読み込んで付加します。内容ボックスに直接ファイル名を入力するか、矢印ボタンを押してファイルを参照します。ファイルの内容にはプリンター言語に加えて予約変数を含むことができ、印刷実行時の情報と置換されます。ファイルの内容は印刷されるたびに読み込まれます。制御コードは理解しやすい代替表記で入力することができます。代替表記の詳しい情報は、制御コードの入力を参照してください。
  • 文字． プレフィックス、またはサフィックス文字列を直接文字列として付加します。直接プリンターコマンドを書くことができます。制御コードを入力したいときは、矢印ボタンを押してドロップダウンリストから選択入力することができます。いくつかの制御コードは可読文字ではありません。これらは入力しても空白や他の代替文字で表示されます。
  • 文字分析． プレフィックス、またはサフィックス文字列を直接文字列として付加します。直接プリンターコマンドを書くことができます。ファイルの内容にはプリンター言語に加えて予約変数を含むことができ、印刷実行時の情報と置換されます。制御コードは理解しやすい代替表記で入力することができます 詳しい情報は、制御コードの入力を参照してください。

内容． プレフィックス、またはサフィックス文字列の内容です。選択した種類によって、ファイルの内容が表示されることがあります。ファイルの内容にバイナリデータや制御コード(プリンターコマンド)が含まれる場合は、可読文字で代替表記される場合があります("<"と">"で囲んだバイト値)。

Closed 制御コードの入力

制御コードは特別な意味を持つ文字で、キーボードからの入力が難しいため、可読文字による代替表記、またはリストからの選択入力ができます。代替表記は"<"と">"文字で囲んで表記します。例えば"エスケープ"の代替表記は<ESC>です。これらのコードはWindowsの入力則に従ってキーボードから入力するか、リストから選択するには、矢印ボタンを押してコードを選択します。

"<"、または">"文字そのものを表記するには、2つ続けて表記します。例えば<ESC>文字そのものは <<ESC>>のように表記します。

Closed 内部パラメータリスト

内部パラメータは、コマンドフォントの中でドライバーの内部状態を参照するときに使用します。プリンターコマンド文字列を作成するとき、プレフィックス、またはサフィックスの中に内部パラメータを使うことができます。内部パラメータは、印刷時に実際の値に置き換えられます。

パラメータ名 | 意味
<X> | コマンドフォントのx座標。プリンター座標に変換されています。
<Y> | コマンドフォントのy座標。プリンター座標に変換されています。
Closed 制御コードリスト

制御コードは特別な意味を持つ文字で、通常ASCIIコードの32以下の文字です。各文字は2つからから3つの慣用表記があります。

16進数表記のASCIIコード | 表記 | 意味(JIS用語)
00 | NUL | Null文字
01 | SOH | ヘッディング開始
02 | STX | テキスト開始
03 | ETX | テキスト終了
04 | EOT | 伝送終了
05 | ENQ | 問い合わせ
06 | ACK | 肯定応答
07 | BEL | ベル
08 | BS | 後退
09 | HT | 水平タブ
10 | LF | 改行
11 | VT | 水平タブ
12 | FF | 書式送り(改ページ)
13 | CR | 復帰
14 | SO | シフトアウト
15 | SI | シフトイン
16 | DLE | 伝送制御拡張
17 | DC1 | 装置制御1(XON)
18 | DC2 | 装置制御2
19 | DC3 | 装置制御3(XOFF)
20 | DC4 | 装置制御4
21 | NAK | 否定応答
22 | SYN | 同期信号
23 | ETB | 伝送ブロック終結
24 | CAN | キャンセル
25 | EM | 媒体終端
26 | SUB | 置換
27 | ESC | エスケープ
28 | FS | ファイル分離標識
29 | GS | グループ分離標識
30 | RS | レコード分離標識
31 | US | ユニット分離標識
Closed オプション

位置． 印刷データ内へのコマンドフォントの挿入位置をある程度制御できます。多くの場合はエレメントの位置へ挿入し、装飾したオブジェクトを印刷します。プリンターの設定を行いたい場合は、ページの前のような別の位置に挿入したいかもしれません。詳細については、使用しているプリンターのコマンドリファレンスもご覧ください。

ノート: どの位置を指定しても、コマンドは印刷するすべてのページに送られます。

  • ページの前． コマンドはページの開始前に挿入されます。
  • エレメントの前． コマンドはページの開始後、すべてのエレメントの前に挿入されます。
  • エレメントの位置． コマンドはエレメントの位置に挿入されます。コマンドはラベルで定義した文字列と連結されます。
  • エレメントの後． コマンドは全てのエレメントの後、ページの終了前に挿入されます。
  • ページの後． コマンドはページの終了後に挿入されます。

ページの開始と終了時には、ドライバーによって初期化と終了のコマンドが自動的に生成されます。これらを抑制したり関与することはできません。

マージ対象． このセクションのオプションは、データを1つの行に、またはページ全体を1つのコンテンツにマージします。複数のオブジェクトから供給されるデータを1つのオブジェクトにエンコードしたいときは、マージを使って1つのストリームにしなければいけません。

このオプションは通常、2次元バーコードやRFIDタグなどの複数のデータフィールドを、1つのデータフィールドとして構成するときに使用します。また一部のWindowsアプリケーションは、1つの文字列を複数の文字列に分解して送信するので(Microsoft Wordなどが知られています)、 コマンドが1度だけ適用されることを保証するためにも使用します。

  • マージしない． マージしません。呼び出しのたびに送信されます。
  • 同一行の文字． 同じフォントを使う同一行の文字に対して、1度だけ送信されます。
  • 同一ページの文字． 同じフォントを使う同一ページの文字に対して、1度だけ送信されます。


フォント置換

予めプリンターにダウンロードしていない限り、スクリーンフォント(例えばTrueType、OpenType、およびPostScriptフォント等)はグラフィックスとしてプリンターに送信されます。グラフィックモードでの印刷は、プリンターフォントを利用した印刷よりはるかに遅いです。また.NET環境や一部のアプリケーションは、プリンターフォントをサポートしていません。そのため最適化したラベルテンプレートの作成が困難になっています。

ドライバーはスクリーンフォントでの印刷をドライバーフォントに置換することで、この問題に対処する方法を提供しています。

このダイアログでは、プリンターフォントとスクリーンフォントを置換し、以下の恩恵を受けることができます：

  • 印刷速度の向上. フォントはグラフィックとして印刷されず、ドライバーフォントとして印刷されます。
  • 既存のラベルのデザインを一切変更する必要がない． スクリーンフォントを使用してデザインした、既存のラベルを再利用することができます。フォント置換はドライバーの機能で独立しており、ラベルのデザインとは無関係だからです。
  • 同じテンプレートを異なるプリンターで印刷できる． 一つの最適化されたラベルテンプレートを異なるプリンターで使用する事ができます。
Closed フォント置換ダイアログ
  • システムフォント． プリンターフォントに置換するシステムフォントを選択します。このフォントをラベルデザイン時のスクリーンフォントとして使用します。1つのシステムフォントは、1つのプリンターフォントに割り当てることができます。
  • プリンターフォント． スクリーンフォントと置換するプリンターフォントを選択します。このフォントには、スケーラブルフォントを使用する事をお勧めします。スケーラブルフォントを使用すると、スクリーンフォントのデザインサイズに近い印刷結果が得られます。ビットマップフォントを選択した時は、ドライバーはスクリーンフォントに最も近いサイズで印刷します。

ノート: 似たフォントに置換するようにしてください。適切なフォントの選択は、より良いWYSIWYGを得るために重要です。


ドライバー設定

ドライバー設定パネルのプロパティーでは、高度なプリンター設定を変更することができます。

Closed アプリケーションの既定値を上書きする
  • 常にドライバー設定を使う． アプリケーションが指定した全てのプリンター設定を破棄し、常にドライバー設定を使用します。このオプションはアプリケーションの設定にかかわらず、全てのアプリケーションで同じプリンター設定を強制したい場合に使用します。
Closed 互換フォント名
  • フォント名の後方互換． 古いバージョンのソフトウエアで設計されたラベルを開くとき、正しいフォントが選択できるようにします。以前使用可能であった古いフォント名を使用することができるようになります。このオプションは、最新のドライバーで古いラベルデータを使うときに使用します。

例

Arial、Arial Bold、Arial Italic、およびArial Bold Italicフォントは、Arialという名前に統一されています。Bold、Italic、およびその他の修飾名は、もうフォント名の一部ではありません。

新しいフォント名で、ラベルを再設計することを推奨します。


プリンター設定

プリンター設定パネルのプロパティでは、既定のプリンター設定を定義することができます。現在のプリンター設定を取得する、設定値を変更してプリンターに送信することができます。この操作を使用する前には、プリンターが正しく接続され、電源が入っていることを確認してください。

  • プリンターから取得． この操作はプリンターから既定値を取得します。
  • プリンターに送信． このオプションはプリンターと通信し、パネルで設定した全ての値をプリンターメモリーに保存します。設定値はプリンターに保存され、新たなプリンターの既定値となります。
Closed メディア設定

このセクションで入力する値の既定の単位は、Windowsのインターナショナルパネルで設定した単位です。単位の略号を明示的に追加することで、他の計測単位で入力することができます。入力した値は既定の単位に変換されて、 プレビューウインドウに表示されます。

  • ラベル幅． ラベルの幅を入力します。
  • ラベル高さ． ラベルの高さを入力します。
  • メディアの種類． ラベルプリンターで使用するメディアの種類を選択し、センサーを設定します。通常ダイカットラベルでは、ラベルを正しくカットしたり送るために、各ラベルを検出するメカニズムを必要とします。この目的のためにラベル間を検出する反射センサーなど、様々なセンサーが使用されます。別のオプションは、ラベルの前に印刷した黒いマークを検出するセンサーなどがあります。
Closed 詳細
  • ギャップ付きラベル 最も一般的なラベルです。抜き加工された、最も一般的なラベルです。プリンターは光センサーでラベル間のギャップを検出します。ラベル間のギャップによって、プリンターは印刷ヘッドの下に次のラベルを送ることができます。
  • 連続ラベル． 抜き加工されておらず、ラベル間のギャップがないラベルです。通常は内蔵カッターによって、指定サイズで切り取られます。
  • 黒マーク付きラベル． 予め台紙に検出用の黒マークが印刷されているラベルです。黒マークによって、プリンターは印刷ヘッドの下に次のラベルを送ることができます。
  • ギャップサイズ． ダイカットラベルにおける、ラベルとラベルの間隔です。
Closed 印刷オプション
  • 縦基点． 垂直方向のオフセット値です。垂直方向の印刷位置を微調整します。
  • 横基点． 水平方向のオフセット値です。水平方向の印刷位置を微調整します。

ノート: プリンターによっては、負の補正値を指定する事もできます。

これらのオプションの組み合わせは、十分注意して使用する必要があります。速度を大きくすると、メディアは速く搬送されるようになります。印刷時間を短縮しますが、印刷品質は低下します。速度設定を下げることなく濃度設定を大きくすると、印刷ヘッドが過熱する可能性があります。メディアとリボンの種類に基づいて、適切な設定値を見つけてください。

  • 速度． メディアの搬送速度を指定します。ドロップダウンリストから、プリンターがサポートする値の一つを選択してください。ドロップダウンリストから、プリンターがサポートする値の一つを選択してください。
  • 濃度． 印刷濃度を微調整します。これは印刷ヘッドの温度に反映されます。高温の設定では濃く印刷されます。
  • 濃度レンジ． 使用するメディアに合わせて、印刷濃度を大まかに調整します。詳細については、プリンターのユーザーガイドを参照してください。
  • 印刷モード． 熱転写印刷は、インクリボンを使用して様々なラベルに堅牢な印刷をすることができます。感熱印刷は、感熱紙を使用して直接用紙に印刷しhます。感熱印刷は光や熱に敏感で、印刷は堅牢ではありません。
  • 用紙切れ検出． 用紙切れの検出方法を設定します。用紙の種類 - ロール、またはファンフォールドを選択してください。
  • バッチマーカー． 印刷開始位置を明認するためのラベルを印刷するか設定します。
  • 無し． バッチマーカーを使用しません。
  • マーカー． 最初のラベルの端に黒いマークを印刷します。
  • セパレーター． 最初のラベルを次以降のラベルより2 mm長くカットします。
  • 動作モード． 定義済みの動作モードから選択します。
  • 連続． ラベルを印刷した後に、次のラベルの印刷位置で停止します。直ちに次のラベルを印刷することができます。
  • ティアオフ． ラベルを印刷した後に、切り取りエッジで切り取る(手切りモード)ことができます。ラベル間が切り取りエッジに来るように送り出されます。
  • カッター． ラベルを印刷した後に、カッターモジュールによって切り取ります。各ラベルを印刷するたび、または一連の印刷ジョブの後にカットします。
  • 剥離． ラベルを印刷した後に、剥離エッジで剥離することができます。ラベルを剥離エッジから取り出すと、次のラベルが印刷されます。
  • ノンセパ． 台紙の無い連続メディアを使用することができます。通常カッターモジュールによって、適切なラベルサイズに切り取られます。
  • カッター-印刷中にカット． 印刷中にラベルをカットします。
  • ティアオフオフセット． 動作モードがティアオフの場合、ラベルが適切な位置で停止するように調整をします。
  • ティアオフ待機時間． 印刷終了後にデータがない場合に、ティアオフ位置までフィードする待機時間です。
  • 剥離モード． 印刷データを受信後に1枚だけ印刷して剥離エッジで待機します。ラベルが剥離エッジから取り出されると、次のラベルを1枚印刷します。
    • 印刷の前． 次のラベルの印刷前に剥離動作を行います。
    • 印刷の後． ラベルの印刷後に剥離動作を行います。
    • バックフィード無し． ラベルを取り出しても、バックフィード動作を行いません。
  • 剥離オフセット． 動作モードが剥離モードの場合、ラベルが適切な位置で停止するように調整します。
  • ノンセパ． 台紙のないノンセパロールラベルを使用します。
    • 印刷の前． 次のラベルの印刷前にカット動作を行います。
  • ピッチオフセット． ラベル端(最初にプリンターから出た端)と次のラベル端までの距離です。
Closed カッター設定
  • カッターモード． カッターを使用します。このオプションを有効にするときは、カッターモジュールが搭載されていることを確認してください。

    • 印刷の前 次のラベルの印刷前にカット動作を行います。

    • バックフィード無し カット動作を行っても、バックフィード動作を行いません。
    • 印刷の後 ラベルの印刷後にカット動作を行います。
  • カットオフセット． ラベルカット位置の調整を行います。
  • イジェクト延期時間． ラベルをカットするまでの延期時間を調整します。
Closed 文字印刷設定
  • 文字間隔． 文字間隔を選択します。固定は各文字が同じ文字間隔で印刷されます。プロポーショナルは、各文字が異なる間隔で印刷されます。X 例えばプロポーショナルの'm'と'i'は異なる幅を持ちます。
  • 漢字コード． 漢字のエンコード形式を指定します。JIS、またはShift JISを指定します。
  • 斜線付き0． '0'に斜線'/'付を使用するか選択します。斜線付の0は、アルファベットの'O'と数字の'0'の区別が重要なときに使用します。このオプションは、プリンターの0斜線対応フォントを使用しているときのみ有効になります。
Closed ハードウエア設定
  • LCDパワーセーブ． LCDのバックライトを消灯するまでの時間です。常時バックライトを点灯したいときは、00分を設定してください。バックライトを消灯してもメッセージは表示されたままです。LCDそのものの電源を切るわけではありません。
  • エラー時にブザーを鳴らす． エラー発生時にプリンターのブザーを鳴らすか指定します。プリンターに問題が生じたことを確認しし易くなります。
  • 電源ON時にフィード． プリンターの電源をONにした時に次のラベル位置まで空送りします。このオプションを有効にしておくと常に正しい位置から印刷を開始することが出来ます。


RFID設定

RFID設定パネルのプロパティでは、RFIDタグの設定を管理することができます。またRFIDデータの読み書きで生じたエラーの原因を把握し、対処する情報を提示します。

  • カウンターの消去． プリンターの内部カウンターをリセットします。
  • 設定の取得． プリンターからRFID設定を取得します。
  • 設定の送信． プリンターへRFID設定を送信します。
Closed PJMスタックタグ(PJM統合)

この設定グループでは、PJM(フェーズジッタ変調) RFIDタグのプロパティを定義します。

  • RFIDモジュール． ラベルのRFIDモジュールを有効、または無効にします。
  • エラーが発生したとき． エラーが発生したときの印刷を有効、または無効にします。
  • 最大リトライ． エラー発生したときの最大印刷リトライ回数を設定します。
  • モジュールリトライ． RFIDモジュールに書き込みエラーが発生したときの最大リトライ回数を設定します。
  • RFIDタグオフセット． ラベル端からRFIDモジュールまでの距離を入力します。


メンテナンス

メンテナンスパネルのプロパティでは、以下の2つのプリンター設定グループをインポート、またはエクスポートすることができます：

  • 現在のユーザー設定： これらの設定は、現在のログオンユーザーの設定です。
  • 印刷の既定値． これらの設定で、印刷の既定値(プリンターとドライバーの既定値)を変更することができます。印刷の既定値は、新しいユーザーとこれまで一度も設定を変更していないユーザー - このコンピューターと共有プリンターを使用するワークステーションユーザーの既定値として使われます。
Closed 現在のゆーざー

このグループは、現在のログオンユーザーに設定をインポートするか、設定をエクスポートします。設定を同じ名前でログオンする他のコンピュータ上の、互換性のあるドライバー間で交換することができます。

インポート． 現在のログオンユーザーに設定をインポートして適用します。別のプリンターから設定をインポートした時は、このプリンターで使用可能なパラメータのみが使用されます。

インポート動作に関する詳しい情報は、 ここを参照してください。

エクスポート． 現在のドライバー設定を外部ファイルに保存します。このファイルは、バックアップ、または設定を他のコンピューターへ複製する時に使用できます。

エクスポートファイルは、以下の内容を含んでいます：

  • ドライバー設定
  • カスタムストック
  • バーコードとコマンドフォント
  • ダウンロードしたオブジェクト

これらの全てのプロパティは、.DRXという拡張子の付いたファイルに保存されます。設定は互換性のあるプリンターモデル間で交換することができます。

ノート: 定義ファイルにサポートしていないデータが含まれているときは、サポートしていないデータはインポートされません。

インポートとエクスポートは、コマンドラインユーティリティを使用して実行することもできます。詳しい情報はコマンドラインインポートツールを参照してください。

ノート: これらの設定は、同じユーザー名でログオンしている場合にのみ反映されます。

Closed 印刷の既定値

このグループは、印刷の既定値をインポートするか、既定値をエクスポートします。

印刷の既定値ウインドを開くには、ドライバーのプロパティ、詳細設定タブ > 標準の設定 ... ボタンをクリックします。

インポートは、印刷の既定値をインポートします。新しいユーザーと、これまで一度も設定を変更していないユーザーの既定値として使われます。定義ファイルにサポートしていないデータが含まれているときは、サポートしていないデータはインポートされません。

インポート動作に関する詳しい情報は、 ここを参照してください。

エクスポート は、印刷の既定値を外部ファイルに保存します。

ノート: インポートとエクスポートの実行は、管理者権限が必要です。

Closed ストリームログ

ノート: この機能は、プリンタードライバーのトラブルシューティングに使用される高度な機能です。技術サポートに指示されない限り、この機能は有効にしないでください。

このプロパティは、ドライバーとプリンターとの間で送受信される情報を記録することができます。

このプロパティを有効にすると、ドライバーはプリンターに送受信したデータを記録します。ドライバーは印刷ストリーム(ラベル情報)と、双方向通信データ(制御メッセージ)を異なるファイルに保存します。各ラベル情報と制御メッセージは、印刷毎に重複しないファイルに保存されます。

  • 有効． ストリームログを有効にします。トラブルシューティングを終了したら必ず無効にしてください。負荷の大きいシステムでは、プロセッサとハードディスクのリソースを消費します。

ノート: 双方向通信データを正しく保存するには、双方向通信が可能なインターフェイスを使用し、なおかつ双方向サポートを有効にしなければいけません。ドライバーの プロパティ > ポートタブ > 双方向サポートを有効にするをチェックしてください。

  • 出力ディレクトリ． ストリームログを書き込むフォルダを指定します。ストリームログには固有のサブフォルダと名前が自動的に付けられるので、常に同じフォルダを指定することができます。

    ノート: 出力ディレクトリの設定は、ダイアログボックスを閉じたときに反映されます。パスを変更したときは、ダイアログボックスを閉じて設定を反映してください。


インターナショナル

インターナショナルパネルのプロパティでは、ドライバーのユーザーインターフェイス言語を設定することができます。

ドライバーのユーザーインターフェイスは、主要なすべての言語をサポートしています。選択した設定は、次回ドライバーのプロパティを開いたときに反映されます。

Windowsのシステムの地域と言語のオプションを開くダイアログボックスを開きます。このダイアログボックスでは、日付/時間、数値、通貨の表示方法を設定することができます。


ページ設定

ノート: このパネルのオプションはプリンターに依存します。

ページ設定パネルのプロパティでは、 ストックを選択してメディアの設定、幅、高さや回転方向などを設定することができます。ストックを選択するとページコントロールはストックの定義で上書きされて変更できなくなります。

Closed プリンター設定

ラベル印刷に使用するストックを選択し、印刷コピー枚数を定義します。

  • ストック． 定義済みストック、またはユーザー定義ストックをドロップダウンリストから選択します。
  • 用紙「ユーザー定義」のIDを257に変更する。 ユーザー定義用紙のIDに256以上を要求するアプリケーションとの互換性を維持します。
  • コピー． ラベルのコピー枚数を定義します。

ノート: 緑色のチェックボックスは、設定をプリンターに送信するか、プリンターの既定値を使うか指定します。チェックボックスをクリックして、送信オプションを選択します。SATO 既定値か、自動的に選択された設定の利用をお勧めします。

Closed メディア設定

このセクションで入力する値の既定の単位は、Windowsのインターナショナルパネルで設定した単位です。単位の略号を明示的に追加することで、他の計測単位で入力することができます。入力した値は既定の単位に変換されて、 プレビューウインドウに表示されます。

  • ラベル幅． ラベルの幅を入力します。
  • ラベル高さ． ラベルの高さを入力します。
  • メディアの種類． ラベルプリンターで使用するメディアの種類を選択し、センサーを設定します。通常ダイカットラベルでは、ラベルを正しくカットしたり送るために、各ラベルを検出するメカニズムを必要とします。この目的のためにラベル間を検出する反射センサーなど、様々なセンサーが使用されます。別のオプションは、ラベルの前に印刷した黒いマークを検出するセンサーなどがあります。
Closed 詳細
  • ギャップ付きラベル 最も一般的なラベルです。抜き加工された、最も一般的なラベルです。プリンターは光センサーでラベル間のギャップを検出します。ラベル間のギャップによって、プリンターは印刷ヘッドの下に次のラベルを送ることができます。
  • 連続ラベル． 抜き加工されておらず、ラベル間のギャップがないラベルです。通常は内蔵カッターによって、指定サイズで切り取られます。
  • 黒マーク付きラベル． 予め台紙に検出用の黒マークが印刷されているラベルです。黒マークによって、プリンターは印刷ヘッドの下に次のラベルを送ることができます。
  • メディアフォーム． ラベルの送りモードを設定します。ファンフォールドロールラベルで使用することができます。
  • 回転． ラベル印刷の回転方向を指定します。プレビューウインドウで、どのように印刷されるか表示されます。
  • ミラーラベル． このオプションを有効にすると、鏡に映ったようにX、またはY座標を入れ替えます。このオプションは、使用できないプリンターがあります。’


印刷オプション

ノート: このパネルのオプションはプリンターに依存します。選択したプリンターでサポートしているオプションのみが表示されます。

印刷オプションパネルのプロパティでは、印刷速度や印刷品質を設定することができます。選択したプリンターによっては、印刷基点の調整、その他プリンターオプションの設定を行うことができます。

Closed 印刷設定
  • 速度． メディアの送り速度です。ドロップダウンリストから、プリンターがサポートする速度を選択します。
  • 濃度． 印刷濃度を微調整します。これは印刷ヘッドの温度に反映されます。高温の設定では濃く印刷されます。
  • 濃度レンジ． 使用するメディアに合わせて、印刷濃度を大まかに調整します。詳細については、プリンターのユーザーガイドを参照してください。
  • 印刷モード． サーマルプリンターの動作モードを設定します。
    • 熱転写． インクリボンを使用して印刷します。
    • 感熱． 感熱紙を使用して印刷します。
Closed オフセット

ラベルに含まれるコンテンツに比例して、ラベルの位置を調整します。印刷基点の微調整を行います 既定の計測単位で入力します。

  • 上． 垂直方向の印刷基点を微調整します。
  • 左． 水平方向の印刷基点を微調整します
Closed 他の計測単位で値を入力する

既定の計測単位以外で値を入力するには、値の後に計測単位を明示します。

計測単位には、以下の略号を使用することができます。

略号 | 計測単位
" インチ
mm | ミリメートル
cm | センチメートル
Closed 高度な設定
  • 連続ラベルの固定ドキュメント長． プリンターは印刷の後、ラベル全体を適切な位置まで送ります。ダイカットラベルの場合は、送り量はセンサーによるラベル間検出で決定できます。連続ラベルの場合はセンサーによる送り量が決定できないので、ラベルの長さを定義しておく必要があります。ラベルの長さの定義はストックの設定で個々に、またはこのオプションで共通に設定します。
  • 固定エレメントを最初のページにのみ送る (オーバーレイ機能). このオプションを有効にすると、全ての固定エレメントが印刷ジョブの最初のページのみに送られます。次以降のページでは可変エレメントのみが送信され、 固定エレメントはプリンターメモリーからリコールして印刷します。
  • 古いRFIDロックコマンドを使う． このオプションを有効にすると、古い"lck"形式のRFIDロックコマンドを使用します。無効にすると、"lc"形式のRFIDロックコマンドを使用します。


印刷モード

ノート: このパネルのオプションはプリンターに依存します。選択したプリンターでサポートしているオプションのみが表示されます。

印刷モードパネルのプロパティでは、オプションのプリンターハードウエア設定をおこなうことができます。

いくつかのオプションでは、設定項目の横にチェックボックスが表示される場合があります。チェックボックスを使用すると、ドライバーからハードウエア設定を制御するか、またはプリンターの既定値を使用するか指定する事ができます。

Closed バックフィード
Closed 動作モード
  • 連続． ラベルを印刷した後に、次のラベルの印刷位置で停止します。直ちに次のラベルを印刷することができます。
  • ティアオフ． ラベルを印刷した後に、切り取りエッジで切り取る(手切りモード)ことができます。ラベル間が切り取りエッジに来るように送り出されます。
  • カッター． ラベルを印刷した後に、カッターモジュールによって切り取ります。各ラベルを印刷するたび、または一連の印刷ジョブの後にカットします。
  • 剥離． ラベルを印刷した後に、剥離エッジで剥離することができます。ラベルを剥離エッジから取り出すと、次のラベルが印刷されます。
  • ノンセパ． 台紙の無い連続メディアを使用することができます。通常カッターモジュールによって、適切なラベルサイズに切り取られます。
  • カッター-印刷中にカット． 印刷中にラベルをカットします。
Closed バックフィードモード

いくつかの動作モード、例えばカッターや剥離モードでは、印刷後のラベルをカットしたり剥離する位置に移動しなければいけません。そして次のラベルを印刷する時は、印刷ヘッドの下まで戻さなければいけません(バックフィード)。このオプションは、バックフィード動作を制御します。

  • バックフィード無し． バックフィードしません。
  • 次のドキュメントの前． 次のドキュメントを印刷する前にバックフィードします。次のドキュメントを印刷するまでラベルが送り出し位置に留まるので、これは剥離モードで有用です。
  • ドキュメントの印刷後． ドキュメントを印刷した後にバックフィードします。次のドキュメントを印刷しなくともハードウエアオプションの動作が可能なので、これはカッターモードで有用です。
Closed バックフィードオフセット

ラベルとラベルの間で停止する(ティアオフモード)、正しい剥離位置で停止する(剥離モード)、または正しいカット位置で停止する(カッターモード)ように、ラベルの送り出し量を微調整します。値は既定の単位で入力します。負の値を入力することもできます。

Closed ピッチオフセット

ラベルピッチは、最初にプリンターから出てくる端と次のラベル端間の距離です。ピッチの量を1 mm単位、+/- 49 mmの範囲で補正します。負の値はプリンター側、正の値は送り出し側へ補正します。

Closed 他の計測単位で値を入力する

既定の計測単位以外で値を入力するには、値の後に計測単位を明示します。

計測単位には、以下の略号を使用することができます。

略号 | 計測単位
" インチ
mm | ミリメートル
cm | センチメートル
Closed カッター

種類は、カッター動作の種類を設定します。

  • 無し． カッターを動作させません。
  • バッチ． 印刷したラベルは、一連のバッチの最後にカットされます。
  • ラベル． 印刷したラベルは、指定した枚数でカットされます。

ラベルを指定したときは、その枚数に達するたびに、繰り返しカットされます。


バーコード検証

一部のSATOプリンターモデルは印刷直後のバーコードを読み取って、1次元と2次元バーコードを検証することができます。

バーコード検証パネルのプロパティでは、読み取りと検証の方法を設定することができます。

Closed 設定

設定グループは、バーコードをどのように検証するか設定します。

  • モード． バーコード検証機の動作モードを設定します。
    • 無効. バーコード検証機を無効にします。バーコードは検証せずに印刷されます。
    • 読み取り. バーコードが読み取り可能であるか検証します。
    • 比較. バーコードの読み取り結果が印刷データと一致するか検証します。
  • バーコード番号 の設定. 検証したバーコードの最大数を設定します。
    • コマンド. 最大数はバーコード検証機のダイレクトコマンド数を設定します。
    • 設定. 最大数はプリンタードライバーインターフェイスで使用可能な数を設定します。
  • ラベル上のバーコード. 一枚のラベル上で使用可能な、検証するベーコード数を設定します。数値の上限は10です。より多くの値を入力しても自動的に減らされます。
  • 開始位置. バーコード検証機がスキャンを開始する位置を調整します。印刷開始位置から指定した位置を経過した所から検証されます。一枚のラベルに複数のバーコードがあるとき、検証するバーコード位置を指定するために使用します。
  • VOID印刷. バーコードの読み取り、または値の検証でエラーとなった場合にエラーマークを印刷します。
    • VOID印刷有効. バーコードの読み取り、または値の検証でエラーとなった場合に、一時停止せずにエラーマークを印刷します。VOID印刷後に、プリンターは同じラベルを再試行数に達するまで印刷再試行します。再試行数に達しても印刷に成功しない場合は、プリンターはエラーメッセージを表示して停止します。
    • VOID印刷無効. バーコードの読み取り、または値の検証でエラーとなった場合に、プリンターはエラーメッセージを表示して停止します。
  • 再試行数. バーコードの読み取り、または値の検証でエラーとなった場合に、プリンターが再試行する回数を入力します。


グラフィックオプション

グラフィックパネルのプロパティでは、ドキュメントに含まれるグラフィックオブジェクトの処理を設定します。

ノート: グラフィックのプロパティは選択したプリンターモデルに依存します。

Closed ディザ

ディザはカラーイメージを熱転写プリンターが印刷できる白黒イメージに変換する処理方法です。

  • 写真スライダー． ディザ効果の強さを調整します。粗い効果から細かい効果まで調整できます。イメージが最も良好に表示されるレベルを選択してください。プレビューウインドウでは、イメージがどのように処理されるか表示されます。

ノート: カラフルなイメージは、写真寄りの設定をお勧めします。スポットカラーのイメージは、クリックアート寄りの設定をお勧めします。イメージの外側にドットが発生する時は、写真寄りに調整してください。

Closed ディザとは何か?

通常熱転写プリンターは1色 - 黒のみが使用できます。また個々の印刷ドットの濃度を調整する事もできません。

熱転写プリンターの印刷濃度設定はラベル全体に適用されます。個々の部分の濃度を変更することはできません。この制約はラベルに文字、バーコード、単色のイメージを印刷する場合には大きな問題ではありません。しかしグレースケールやカラーのイメージを印刷したい場合は、印刷結果に課題が生じる場合があります。

ディザは異なるサイズのドットパターンを使用して、カラー、またはグレースケールイメージを白黒イメージに変換する手法です。異なる形状、サイズ、ドット間の距離を調整する事で白黒イメージに変換します。この手法は単純な二値化処理より高品質なイメージを得ることができます。

Closed プリンターグラフィックオプション

グラフィックの種類． イメージをどのようにエンコーディングするか設定します 利用可能なオプションは、選択したプリンターに依存します。

  • バイナリ． プリンター既定のエンコーディング方式を使います。
  • PCX. 圧縮PCX形式でエンコーディングします。
  • ASCII. 7ビットASCIIテキスト形式でエンコーディングします。バイナリデータが含まれません。


カスタムコマンド

カスタムコマンドパネルのプロパティでは、カスタムプリンターコマンドを定義してプリンターに送信することができます この機能から言うと、カスタムコマンドとコマンドフォントは殆ど同じです(実際カスタムコマンドはコマンドフォントで代替できます)。 本質的な違いは、自動的に定型データを送信するだけ(カスタムコマンド)か、データの自由度は高いがプログラムによる明示的な送信が必要(コマンドフォント)かの違いです。 カスタムコマンドダイアログボックスでは、以下のオプションを使用する事ができます。

  • 印刷の前． 新しい印刷ジョブの前に、1つまたはそれ以上のカスタムコマンドを挿入します。この設定は印刷ジョブ全体に影響を与えます。このコマンドは、一つの印刷ストリームに含まれる全てのラベルに適用されます。
  • 最初のページの前． 最初のページの前に、1つまたはそれ以上のカスタムコマンドを挿入します。
  • 各ページの前． 各ページの前に、1つまたはそれ以上のカスタムコマンドを挿入します。
  • 各ページのエレメントの前． 各ページのエレメントの前に、1つまたはそれ以上のカスタムコマンドを挿入します。
  • 各ページのエレメントの後． 各ページのエレメントの後に、1つまたはそれ以上のカスタムコマンドを挿入します。
  • 各ページの後． 各ページの後に、1つまたはそれ以上のカスタムコマンドを挿入します。
  • 最後のページの後． 最後のページの後に、1つまたはそれ以上のカスタムコマンドを挿入します。このコマンドは、ドキュメントの最後のページに適用されます。
  • 印刷の後． 印刷ジョブの終了時に、1つまたはそれ以上のカスタムコマンドを挿入します。

各コマンドは、異なる方法で送信する事ができます：

  • 空． カスタムコマンドを使用しません。
  • ファイル． カスタムコマンドを選択したファイルから読み込みます。ファイルのデータはASCIIテキスト、またはバイナリーデータを含むことができます – 使用するプリンターの言語に依存します。
  • 文字． 内容ボックスに文字列を入力します。使用可能な文字列はプリンターの依存しますが、一部の制御コードはキーボードからの入力が困難です。矢印ボタンを押して、制御コードを入力することができます。
  • 文字分析． 内容ボックスに文字列を入力します。矢印ボタンを押して、制御コードを入力することができます。加えて制御文字を代替表記で入力することができます。

例

内容ボックスで、0x01を<SOH>のような代替表記で入力することができます。SOHは制御文字なので、そのまま入力すると化けて表示されます。

  • ファイル分析． カスタムコマンドを選択したファイルから読み込みます。加えて制御文字に代替表記を使うことができます。


メンテナンス

メンテナンスパネルのプロパティでは、全てのドライバー設定を既定値に戻すことができます。

Closed ドライバーの既定値に戻す
  • リセット 全てのドライバー設定値を既定値に戻します。


インターナショナル

インターナショナルパネルのプロパティでは、ドライバー設定で使用する単位を設定することができます。

  • 単位． 計測単位を選択します。単位は明示的に指定する事がますが、省略した場合はWindowsの設定値となります。
  • Windowsのシステムの地域と言語のオプションを開くダイアログボックスを開きます。このダイアログボックスでは、日付/時間、数値、通貨の表示方法を設定することができます。


技術サポートに連絡する

SATOプリンタードライバーをご使用時には、技術サポートの対象となります。

  1. 最新のWindowsプリンタードライバーをダウンロードするには、次のURLをご覧ください：http://www.satoworldwide.com/software/gallerydriver.aspx
  2. お近くの技術サポートは、次のURLをご覧ください：https://www.satoworldwide.com/contact-us.aspx


インポート動作の詳細

インポートは、以下のように動作します。

  • 有効なドライバー設定． 有効なドライバー設定は、そのままで反映されます。

例：ラベル幅が48 mmから40 mmに減少する場合。そのまま40 mmとして読み込まれます。

  • 無効なドライバー設定． 無効なドライバー設定は、受け入れられる値に変更して読み込まれます。

例：ラベル幅が48 mmから70 mmに増加する場合(プリンターは70 mmを印刷できないものとします)。可能な最大幅に変更して読み込まれます(例えば58 mm)。

  • 使用できないプリンター設定． 値は使われませんが保持されます。

例：カッター機能が無いプリンターにカッター設定を読み込む場合。カッター設定は使われませんが、設定値は保持されています(再エクスポートが可能)。

設定をエクスポートしたとき、実行環境のメタデータが埋め込まれます。このデータは SATOのサポートによって、問題の解決のために使われることがあります。メタデータはシステム情報などの有用な情報が含まれています。

ノート: メタデータはエクスポートのみが可能です。SATOのユーザーサポートのためだけに使用されます。